Campus Telephony Services
Incident Report for La Salle College High School
Resolved
Phone service has been restored. We apologize for any inconvenience.
Posted 20 days ago. Oct 01, 2019 - 13:07 EDT
Investigating
We are investigating reports of interruptions to campus telephony services. There may be interruptions to internal and external calling. We are investigating the issue and will post additional details as they become available.
Posted 20 days ago. Oct 01, 2019 - 08:01 EDT
This incident affected: Phone System.