LSCHS.org Website Connectivity
Incident Report for La Salle College High School
Resolved
This incident has been resolved.
Posted 7 days ago. Sep 11, 2019 - 12:41 EDT
Investigating
Our website vendor is currently an issue with the school website. We apologize for the inconvenience and will continue to provide updates as they investigate further.
Posted 7 days ago. Sep 11, 2019 - 09:33 EDT
This incident affected: Website.