FinalSite Login Issues
Incident Report for La Salle College High School
Resolved
The incident has been resolved. Logging into the Student/Faculty portals as well as Finalsite will now use Single Sign-on (SSO) with Office 365, so the login process may have some visual differences. Please forward any error messages to support@lschs.org if any are received.
Posted Jul 19, 2022 - 13:11 EDT
Investigating
We are aware of a wipe-spread issue with failed logins to FinalSite. We are working with FinalSite Support to find a fix and will roll out the fix as soon as it is found.
Posted Jul 18, 2022 - 12:54 EDT
This incident affected: Website.