LSCHS.org Website Connectivity
Incident Report for La Salle College High School
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted 3 months ago. May 17, 2019 - 14:42 EDT
Investigating
Our website vendor is currently an issue with the school website. We apologize for the inconvenience and will continue to provide updates as they investigate further.
Posted 3 months ago. May 17, 2019 - 13:57 EDT
This incident affected: Website.