Portal Login
Incident Report for La Salle College High School
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 12, 2018 - 21:54 EST
Investigating
We are currently investigating difficulties with LSCHS Portal Login.
Posted 9 months ago. Jan 12, 2018 - 14:12 EST