School Website
Incident Report for La Salle College High School
Resolved
Finalsite has identified and fixed the issue with the school website. We apologize for the inconvienence.
Posted 5 months ago. May 22, 2018 - 16:18 EDT
Identified
Finalsite has identified the issue with the school website and is working to implement a fix. For grades and attendance, please visit https://lschs.seniormbp.com and use your regular La Sale Credentials. We apologize for the inconvienence.
Posted 5 months ago. May 22, 2018 - 11:10 EDT
Investigating
We are currently investigating reports of difficulties access the school website. Our vendor has reported server difficulties at this time. We will post more information as it becomes available.
Posted 5 months ago. May 22, 2018 - 10:57 EDT
This incident affected: Website and Community Portals.